vSphere web client login error: "Client is not authenticated to VMware Inventory Service"

This week received the following error when trying to login to vSphere web client.
“Client is not authenticated to VMware Inventory Service”

Troubleshooting:

Was able to login with local user “administrator@vsphere.local”.
Problem seems to be only related to domain user authentication.

Looked at all services on vcenter server, which was running.
Service health on vSphere web client also all green without any errors.

Solution:

Finally looked at VMware KB articles and found the following:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2059637

Group names with permissions seems to be case sensitive.
Our domain admin has change the security groups cases and we were not notifiied which cause to the authentication to fail.

Resolved by removing and re-adding the active directory security groups back under permissions for the objects it was registered on.

I would recommend notifying your Domain administrators regarding this issue.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s